Email issues support@chatlayer.ai
Incident Report for Chatlayer
Resolved
The email issues have been resolved and support@chatlayer.ai is up and running again.
Posted Aug 24, 2021 - 10:27 CEST
Investigating
We are currently experiencing email issues and emails sent to support@chatlayer.ai may not be received.
If you would like to log a Support ticket, please use https://support.chatlayer.ai/ and click 'submit a request' in the right upper corner.

Our apologies for the inconvenience.
Posted Aug 24, 2021 - 09:45 CEST