Webwidget V2
Incident Report for Chatlayer
Resolved
This incident has been resolved
Posted Jun 11, 2024 - 11:33 CEST
Investigating
We are currently investigating this incident.
Posted Jun 11, 2024 - 10:13 CEST
This incident affected: Chatlayer Webwidget V2.